Resourcen Autoupdate geht nicht mehr

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Resourcen Autoupdate geht nicht mehr

    Hallo,

    Nachdem ich ein neues Projekt angelegt habe mit einfacher OGL 2D Darstellung habe ich neue Texturen in der Ressourcenverwaltung geadded.
    Das Problem ist, ändere ich die Grafiken mit Photoshop verwendet mein Programm dennoch noch die alten.

    Weder Product Clean noch das löschen und neu Erzeugen des DerivedData noch das neustarten von XCODE etc. ändern etwas daran.
    Selbst das löschen der Textur ( als referenz und auf dem Datenträger ) und neues Hinzufügen unter selben namen ändert nichts daran
    das das bild immer noch doppelt so groß wie ursprünglich dargestellt wird obwohl ich es mittlerweile skaliert habe oder die ressource auf @2x für Retina mode umbenannt habe.

    Das Problem tritt auch nur in diesem neuen Projekt auf, im alten geht alles Tadellos.

    Habe ich irgend etwas irgendwo verstellt ohne es bemerkt zu haben? Wie bekomme ich den Dreher wieder raus? :wacko:
    Hat jemand eine Idee?

    VG
    Markus :thumbsup:
  • Mac & i Test Abo
  • Ah sehr interessant ich habe die App im derived Data, build... geöffnet und dort liegt die neue ...@2x.png datei ab. wenn ich das programm aber auf dem simulator in nicht retina laufen lasse zeigt es das alte bild ab. auf modus retina ipad oder dem echten ipad zeigt es die neue grafik.
    offenbar erzeugt er auf dem software ipad mit Lowresolution das halb so große Texturimage automatisch ( ich war so faul und erzeuge die half sized texturen immer erst am schluss ). und die scheint er nicht geupdatet zu haben. in der app sehe ich diese textur aber nicht. macht das der simulator irgendwie selbst? dann wäre der Fehler dort zu suchen. Oder komme ich nicht umhin immer die halfsized Texturen gleich bei der Entwicklung mit zu generieren?
    Mit Batch Datei geht das mit Autosave mit Photoshop nämlich wunderbar genial einfach am Ende wenn alles fertig ist ganz von selbst.

    VG und Danke schon mal für die Antwort
    Rayjunx
  • IOS SIMULATOR - Inhalte und Einstellungen zurücksetzen - bewirkt wunder. Dann erkennt er die neuen Texturen. Offenbar lagen in seinem Cache irgendwo die Lowres Bilder rum die er nicht updaten wollte. Was er komischerweise beim anderen Projekt immer gemacht hat. Seltsam.
    Also einfach Simulator zurücksetzen wenn komische Dinge mit Euren Texturen passieren, sollte das Problem beheben :thumbup: